Easy banking werd ontwikkeld voor iOS-toestellen met minimum iOS-versie 4 en voor Android-toestellen met OS 2.3 of hoger.