Easy banking a été développé pour les appareils iOS possédant une version iOS 6 ou supérieure et pour les appareils Android possédant une version OS 2.3.3 ou supérieure.