This app Hello bank! update is mandatory. It requires minimum OS 2.3.3. For all your questions, please call +32 (0)2 433 41 45.