Easy banking update

Important

Soon Easy banking will be undergoing a new update. After this update you will be able to add and manage standing orders and see more details regarding your credit card expenditure. Please note: this app update is mandatory for all mobile devices with iOS and Android operating software. Note therefore the operating software on your device:

 

  • For Android users:
    The new update requires at least version OS 2.3.3 as operating software.
  • For iOS users:
    The new update requires at least version iOS 6 as operating software.

 

What should you do if the operating software of your device is not at least O.S. 2.3.3 (Android) or iOS 6 (iPhone & iPad)?

  • You should upgrade the operating software in order to keep using the Easy banking app after the new Easy banking release at the end of May.
  • You can update free of charge. You do this via the 'Settings' menu on your device.
  • This update will also benefit the other apps on your device.

 

What if you are unable to update to O.S. 2.3.3 (Android) or iOS 6 (iPhone & iPad) because your device is too old?

Then you will not be able to use the Easy banking app after the newest release. You can however continue to use PC banking on your device.